Vlan over IP network on the CISCO 1760

Сразу хочу сказать что много эти циски не протянут) у меня был порог на 2 мбит, но конфиг подойдет и к другим платформам.
Схема такая:
Две Cisco 1760 соеденины ip сетью через виланы
каждая циска соединена с каталистом
Задача: виланы 101 и 104 должны быть доступны на двух каталистах

конфиг первой кошки:

ip cef
!
l2tp-class L2TP-CLASS
authentication
password 7 121A0C041104
!
pseudowire-class PW-L2TP
encapsulation l2tpv3
protocol l2tpv3 L2TP-CLASS
ip local interface Loopback0
!
!
interface Loopback0
ip address 10.1.1.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
!
interface FastEthernet0/0.101
description l2toIP
encapsulation dot1Q 101
no cdp enable
xconnect 10.1.1.1 101 encapsulation l2tpv3 pw-class PW-L2TP
!
interface FastEthernet0/0.102
encapsulation dot1Q 102
ip address c.c.c.c 255.255.255.248
!
interface FastEthernet0/0.104
description inet3
encapsulation dot1Q 104
no cdp enable
xconnect 10.1.1.1 104 encapsulation l2tpv3 pw-class PW-L2TP
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 y.y.y.y
ip route 10.1.1.1 255.255.255.255 x.x.x.x

Конфиг второй кошки:
ip cef
!
l2tp-class L2TP-CLASS
authentication
password 7 030752180500
!
pseudowire-class PW-L2TP
encapsulation l2tpv3
protocol l2tpv3 L2TP-CLASS
ip local interface Loopback0
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
speed auto
!
interface FastEthernet0/0.101
description l2toIP
encapsulation dot1Q 101
no cdp enable
xconnect 10.1.1.2 101 encapsulation l2tpv3 pw-class PW-L2TP
!
interface FastEthernet0/0.104
encapsulation dot1Q 104
no cdp enable
xconnect 10.1.1.2 104 encapsulation l2tpv3 pw-class PW-L2TP
!
interface FastEthernet0/0.256
description vpn-bm18-okt6-VimpelCom
encapsulation dot1Q 256
ip address w.w.w.w 255.255.255.248
!
!
ip route 0.0.0.0 0.0.0.0 62.141.115.57
ip route 10.1.1.2 255.255.255.255 62.141.115.69

Теперь еще нужно на каталистах отключить STP на прокидываемых нами валинах
conf t
no spanning-tree vlan 100-104,256

Теперь дебажим и исправляем ошибки
Кросконект делается на лупбэк интерфейс, Первое что нужно проверить пигуются ли лупбэки.
Второе, посмотреть состояние туннеля и сессии.
sh l2tu sess all
В выводе этой команды вы увидите что поднят ли туннель 1 и поднята сессия 1
Команда предоствит информацию о всех поднятых виланах.

Причем если с одной стороны все поднято, это еще не означает что с другой стороны тоже все ок.
проверяйте с двух сторон

show l2tunn session -> Provide state of the tunnel(s). Look for esp state which means established
show l2tunn session all -> Provide more detailed information about the tunnel(s)
show xconnect all -> Provide state of the tunnel(s). Look for up state

Debug commands:
debug vpdn l2x-events
debug vpdn l2x-packets

Полезные ссылки по этой теме

http://aitaseller.wordpress.com/2011/12/13/l2tpv3-vlan-to-vlan/

http://www.informit.com/library/content.aspx?b=Troubleshooting_VPNs&seqNum=45

dump/restore FreeBSD

dump -0uan -L -f — /usr | gzip -2 | ssh -c blowfish root@10.10.10.1 dd of=/root/dump-usr.gz
gzip -d /dump.file.gz | ( cd / ; restore -rf — )

Размонтировать раздел
umount /dev/ipsd0s1e -v

Отформотировать раздел
newfs /dev/ipsd0s1e

Монтируем его обратно
mount /dev/ipsd0s1e /mnt/ipsd0s1e.ufs

Переходим в него
cd /mnt/ipsd0s1e.ufs

Востанавливаем дамп
restore -vfr /dump.file

Полное удаление данных с диска. Shred. Linux

shred -vfz -n 10 /dev/sda
Шред удаляет все без возможности востановить
Удаляет ФАЙЛЫ если указан —remove (-u). По умолчанию файлы не удаляются, так как часто обрабатываются файлы-устройства вроде /dev/hda, а такие файлы нельзя удалять. При обработке обычных файлов большинство людей используют опцию —remove .
Аргументы:
-f, —force
изменить права для разрешения записи, если необходимо
-n, —iterations=N
Переписать N раз вместо указанных (25) по умолчанию
-s, —size=N
очистить N байт (возможны суффиксы вида K, M, G)
-u, —remove
обрезать и удалить файл после перезаписи
-v, —verbose
показывать индикатор прогресса
-x, —exact
не округлять размеры файлов до следующего целого блока;
по умолчанию для не-регулярных файлов
-z, —zero
перезаписать в конце с нулями, чтобы скрыть перемешивание
есть еще вот такая штука
dd if=/dev/urandom of=/dev/sda но как я понял то шред круче :-)

ну а если удалять только один файл то можно так
cat /dev/zero > жертва.txt

Putty как Socks сервер (использование plink.exe)

В составе Putty есть утилита plink.exe а у нее есть ключ -D этот режим позволяеть сделать из удаленной машины сокс (прокси) сервер
Пример
c:\plink.exe -ssh -P порт -l
пользоваетль -pw пароль -D localhost:1080 -N kabzed.net

localhost:1080 это будет доступно на вашей машине
т.е. указав это в настройках браузера как сокс сервер весь трафик браузера будет идти черерез этот сокс
-N не отображает шел удаленной машины
kabzed.net — здесь адрес удаленной машины

netcat nc Послать данные в порт tcp, udp

Для того что бы проверить работу службы syslog
nc -u kabzed.net 514
и пишем что передать потом жмем энтер и контрол ц
-u использовать протокол udp

так же на циске можно прописать проброс 514 порта
ip nat inside source static udp 192.168.0.14 514 внешний_айпи 514 extendable

Справочник по командам LINUX http://www.zabrosov.ru/

1 Передавать файлы (первую команду выполняем на принимающей машине, вторую — на передающей:

$ nc -l 31334 > filename
$ nc 172.16.69.143 31334 < filename 2 Удаленно читать логи (первая — сервер, вторая — клиент): $ nc -f /var/log/messages | nc -l 31334 $ nc 172.16.69.143 31334 3 Использовать вместо telnet (первая — telnet-сервер, вторая — клиент): $ nc -l -p 31334 -e /bin/sh $ nc 172.16.69.143 31334 ============================

Копирование файлов через ssh. scp

Для того что бы скопировать файл
scp /home/file.txt root@kabzed.net:/home
-r для копировании директории

С помощью scp копируем файл «file.txt» с удаленного хоста на локальный:
scp username@remotehost.ru:file.txt /local/directory

Копируем файл «file.txt» с локального хоста на удаленный
scp file.txt username@remotehost.ru:/remote/directory

Копируем директорию «localdir» со всем ее содержимым с локального хоста в директорию «remotedir» на удаленном компьютере:

scp -r localdir your_username@remotehost.ru:/remote/directory/remotedir

Дебаг SIP сессии в Linux

Сохраняет все сип сессии которые перехватываются на интерфейсе и каждая сессия сохраняется в одтельный файл в директорию /tmp

pcapsipdump -i eth0 -d /tmp/ « keep all SIP sessions on tmp folder

ngrep очень похож на tcpdump
### capture all SIP packages on 5060 on all interfaces
ngrep -W byline -td any . port 5060

### capture all SIP packages containing ‘username’ on port 5060 on all interfaces
ngrep -W byline -tqd any username port 5060

tshark

### Filter on RTCP packets reporting any packet loss or jitter over 30ms:
tshark -i eth0 -o «rtcp.heuristic_rtcp: TRUE» -R ‘rtcp.ssrc.fraction >= 1 or rtcp.ssrc.jitter >= 30′ -V

### View a remote realtime capture with a local wireshark:
wireshark -k -i < (ssh -l root 192.168.10.98 tshark -w - not tcp port 22) EXAMPLE: tshark -o "ssl.desegment_ssl_records: TRUE" \ -o "ssl.desegment_ssl_application_data: TRUE" \ -o "ssl.keys_list: 4.2.2.2,5061,sip,/opt/freeswitch/conf/ssl/agent.pem" \ -o "ssl.debug_file:/tmp/tshark.log" \ -i eth0 \ -f "tcp port 5061" Анализ rtp трафика

tshark -o «rtp.heuristic_rtp: TRUE» -R rtpevent
or with tethereal:
tethereal -o «rtp.heuristic_rtp: TRUE» -R rtpevent

Analyze RTP Quality

sudo tshark -q -f ‘udp portrange 16384-32768′ -o rtp.heuristic_rtp:TRUE -z rtp,streams

If you’re doing long-term captures, you may want to get a bit more paranoid about security:

sudo setuid 4755 /usr/bin/dumpcap
dumpcap -f ‘udp portrange 16384-32768′ -i eth0 -w /tmp/qos.pcap
tshark -qr /tmp/qos.pcap -o rtp.heuristic_rtp:TRUE -z rtp,streams